Upgrade the Database

To successfully perform a major Uyuni update, you might need to upgrade the underlying database.

To upgrade to the latest PostgreSQL, see upgrade:db-migration-xy.adoc.

This table shows the PostgreSQL version required for each version of Uyuni and openSUSE:

Table 1. PostgreSQL Versions
Uyuni version Operating System version PostgreSQL version

Uyuni >= 2020.07

openSUSE 15.2

PostgreSQL 12

Uyuni >= 2021.06

openSUSE 15.3

PostgreSQL 13